IMHO, "select" is not the appropriate name here, the more so because "select" is already used to describe the "successfully pick exactly 1 element out of a list" predicate select/3, which should be called "pick/3"...
The name "dict projection" sounds appropriate for this operation
Then the left dict could be called "small dict" and the right dict "big dict" (ok, where's my coat...)
Unit tests for "dict selection"
A simple application
Default parameters which may be overriden with a dict.